Garmin Connect

Posted on
of 2
/ 2
  • I have an iPhone 7, have Strava / Ride GPS (paid to subscribe) and Garmin Connect on it. I managed to download Strava to my Garmin and that all worked last Sunday. I downloaded Ride GPS and when I try to access it from my Garmin (Connect IQ) it generates a device to input to Ride GPS to recognise it but I have no idea where to enter the code.

    I am probably doing something completely stupid and sure it's all very simple!

    Thank you to everyone who's replied, just heading out to try the library computers

  • Try loading the file via the broswer, not the app. App are usually restricted and this doesn’t necessarily work. Go to your garmin account and load the gpx file there to create/save the route, instead of the app, and see what happens.

  • Logged on in the library, using the browser version of Garmin Connect, devide is recognised by the PC, managed to copy the fit and gpx files into New Files. Also copied into Courses.

    Unplugged the device and looked under Connect IQ and Ride GPS, still keeps generating the code to input somewhere.

    Tried synchronizing using the PC but asks me to download Garmin Express (library PC won't let me). Tried uploading the files to Garmin Connect on the browser but both file types fail with a different error

    I think I officially give up!

    Thank you so much to everyone for their help, looks like iPhone navigation and battery pack required!

  • This is what I keep seeing...

    2 Attachments

    • 82448611-CA5B-4924-8E8A-ACF7D01666C9.jpeg
    • F423BB44-B6D6-48D2-AFF7-5EB5DA9F5099.jpeg
  • I think I have it!!!!

    1 Attachment

    • A874AC0B-23B9-4194-8FDC-10D35B1CA567.jpeg

    FYI if you’re wondering why your Garmin isn’t uploading to Strava


    Now working again.

  • Thank you!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Garmin Connect

Posted by Avatar for Vincent_Azmi @Vincent_Azmi